Samsung UE55F7090 T-Con defekt: reparieren oder ersetzen?

  • Moin zusammen,


    ich habe hier einen Samsung UE55F7090SLXZG stehen, der nur noch "blinkte" (Hintergundbeleuchtung periodisch an / aus). Zur Fehlersuche / Eingrenzung habe ich das Mainboard vom Netzteil getrennt. Danach blieb die Hintergrundbeleuchtung an.

    Die Spannungen fürs Mainboard sind auf dem Netzteil (BN44-00633B) auch alle vorhanden.

    Also habe ich den TV weiter zerlegt und bin am T-Con auf drei blaue LEDs gestoßen, von denen bei angeschlossenem Mainboard nur zwei an sind: LED 1 und 2. Die dritte blinkt nur sehr kurz periodisch auf, zusammen mit der Hintergrundbeleuchtung. Die beiden Leitungen zum Panel habe ich bereits abgehängt und jeweils kurz getestet: keine Änderung. Mittlerweile sind beide Leitungen zum Panel ab, keine Änderung, weiterhin blinkt die dritte LED kurz auf, zusammen mit der Hintergrundbeleuchtung. Takt ganz grob getippt 0,5 bis 1 Herz, habe ich bisher nicht nachgemessen.


    Nun suche ich weitere Unterlagen zum T-Con-Board:

    BN41-01939A

    LSF550HQ01

    SK98BN950

    Darunter stehen noch ein paar Zahlen, die ich gerade nicht hier habe. Ein Foto mache ich noch davon, wenn die Zahlen wichtig sein sollten.


    Ausgebaut habe ich das T-Con bisher nicht, nur optisch begutachtet. Zumindest konnte ich keine offensichtlichen Fehler finden. Im Internet habe ich nichts gefunden an Unterlagen dazu. Hat hier jemand vielleicht Infos?


    Auf der Suche nach einem Ersatz-T-Con bin ich auf diverse Seite gestoßen, aber das BN41-01939A für den UE55F7090SLXZG habe ich nicht auftreiben können.


    Für kleinere Modelle wie 40" habe ich z.B. bei ebay-Kleinanzeigen die Nummer BN41-01939A gefunden, aber ich gehe davon aus, dass die wohl kaum passen für den 55" hier. Oder sehe ich das falsch?


    Hier habe ich ein BN41-01939B gefunden, welches laut der Seite für den TV passen sollte:

    https://www.shopjimmy.com/sams…95-00866a-t-con-board.htm

    Jedenfalls ist der TV dort mit gelistet (auf der Seite runter scrollen zu "TV Models").


    Kann mir jemand sagen, ob das wirklich passt?

    Vielleicht hat jemand ggf. ein entsprechendes T-Con, welches er / sie mir verkaufen würde?


    Vielen Dank im Voraus

    KB

  • kboll

    Hat den Titel des Themas von „Sasmung UE55F7090 T-Con defekt: reparieren oder ersetzen?“ zu „Samsung UE55F7090 T-Con defekt: reparieren oder ersetzen?“ geändert.
  • das BN41-01939A und das BN41-01939B sollten eigentlich identisch sein, das B ist vermutlich jüngeren Datums (Also vermutlich Rev. B). Ansonsten mal in der Bucht international suchen. Vieles, was man in D nicht so einfach findet gibt es aus Übersee.


    Und wenn Dein TV da aufgelistet ist wird es vermutlich auch passen.

  • Nach dem Hinweis von felline habe ich weiter gesucht und anhand diverser Angebote heraus gefunden, dass die Versionen A, B und C des T-Con Boards in der Funktion identisch sein sollen. Das T-Con-Board muss nur zum TV passen.


    Also habe ich ein T-Con-Board für 55"-Geräte bestellt. Dieses soll passen für alle Samsung UE55F7xxx und UE55F8xxx, Lieferzeit ca. 4 Wochen.


    Wichtig falls jemand vor dem gleichen Thema steht wie ich und das hier liest: Geräte mit UE55F6xxx benötigen ein anderes T-Con-Board! Diese T-Con-Boards passen nicht für die ...F7xxx und ... F8xxx.


    Sobald ich das T-Con-Board erhalten habe, werde ich es einsetzen und mich mit dem Ergebnis melden.

  • So, hat ein wenig gedauert, aber nun läuft der TV wieder.


    Das erste T-Con hatte ich über AliExpress bestellt, knapp 15€, Lieferzeit drei Wochen. Das hat leider nicht gepasst, die BN-Nummer war dann doch eine andere. Nun habe ich hier ein T-Con BN41-01939C mit folgender Nummer liegen:

    BN95-00861B

    Es stammt von einem UA55F7500BJ . Offenbar ist dort aber doch ein anderes Panel verbaut.

    Damit hatte ich zwar ein Bild, aber gestaucht und überlagert. Die Paneldaten passten also offenbar nicht.

    Falls das jemand benötigt, bitte melden.


    Dann habe ich weiter gesucht und bin in England bei einem Händler auf ein passendes gestoßen:

    Es stammt von einem UE55F7000ST mit gleichem Panel LSF550HQ01, die BN95-Nummer passte auch: BN95-00965B.


    Das Panel hat mich inkl. Versand 42,71€ gekostet und war nach ein paar Tagen bei mir.

    Hätte ich das früher gewusst ;-)


    Wie auch immer: Eingebaut und funktioniert, Freude groß.


    Nun ist mir noch etwas aufgefallen:

    Ich habe mir das defekte T-Con BN41-01939A noch mal genauer angesehen. Dabei ist mir oben links ein Winbond 25... (exakte Nummer habe ich gerade nicht zu Hand, muss ich nachsehen) aufgefallen. Ich gehe also davon aus, dass hier die Firmware drin steckt.

    Die beiden BN41-01939C sehen bis auf den Aufkleber exakt gleich aus, soweit ich das beurteilen kann. Steckt der einzige Unterschied nun im EEPROM? Hat sich das mal jemand genauer angesehen? Könnte man ggf. die Boards umflashen, sofern es sich um die selbe Board-Variante (hier BN41-01939C) handelt?


    Vom defekten Board habe ich die Daten ausgelesen per Eeprommer und Testklammern (geht allerdings erst, nachdem die Kühlplatte entfernt ist), ebenso vom nicht passenden. Das funktionierende Board ist im TV verbaut, ggf. könnte ich dort aber noch mal ran.

    Allerdings kenne ich mich zu wenig mit solchen Firmware-Geschichten aus.


    Hat hierzu jemand Erfahrungen bzw. Wissen, welches mit uns geteilt werden kann?


    Viele Grüße und schon mal ein schönes Wochenende.

  • Derzeit komme ich nur am Wochenende dazu, mich mit dem Thema zu beschäftigen, daher dauert es immer etwas bis zur Antwort.

    Den funktionierenden TV habe ich noch einmal geöffnet und das T-Con ausgebaut.


    Ausgelesen habe ich nun alle drei T-Con-Boards. Es handelt sich jeweils um ein Winbond W25X40CLSIG. Mit meinem Programmer CH341A (Billig-Teil von ebay, tut aber seinen Dienst) und einer Testklammer funktionierte das. Teilweise brauchte ich mehrere Anläufe, hatte aber dann irgendwann den ausgelesenen Inhalt (auch mehrfach gleich ausgelesen), den ich auch gegen den Speicherinhalt des jeweiligen Moduls und gegeneinander vergleichen lassen konnte von der Programmier-Software. Daher gehe ich davon aus, dass das Auslesen richtig funktioniert hat.


    Die Inhalte der unterschiedlichen Boards unterscheiden sich laut HxD, diesen Hex-Editor habe ich genommen zum Vergleichen. Bei den beiden gekauften Board (BN41-1939C) sind die Unterschiede aber gefühlt wenige.


    Auf den beiden gekauften Boards sind offenbar doch auch Unterschiede in der Bestückung vorhanden, das kam aber erst zum Vorschein, nachdem ich den Kühlkörper auch vom funktionierenden Board abgenommen hatte. Unter anderem sind unterschiedliche ?Speicherbausteine? verbaut, zumindest ist die Anzahl unterschiedlich. Das Hühnerfutter scheint weitestgehend gleich bestückt zu sein, ich habe aber nicht jedes Teil einzeln angesehen.


    Trotzdem habe ich den Inhalt vom funktionierenden Board in das vorige gekaufte geflasht (beide BN41-1939C) und in den TV eingebaut, damit startet er aber nicht. Es gehen nur zwei der drei blauen LEDs auf dem T-Con an, auch das backlight des TV geht nicht an. Wieder originale ausgelesene Firmware eingespielt -> TV geht an und zeigt wieder das gestauchte überlagerte Bild, siehe weiter oben.

    Mit der Firmware aus dem originalen defekten Board (BN41-1939A) hatte ich das gleiche Ergebnis.


    Ich gehe nun davon aus, dass die Boards sich für die unterschiedlichen TV doch weiter unterscheiden und nicht so baugleich sind, dass die Firmware hin- und her geflasht werden kann.

    Meine Möglichkeiten, hier weiter zu testen, sind aufgrund mangelnder Kenntnisse zu ende, jedenfalls weiß ich derzeit nicht weiter.

    Wenn jemand Interesse an den Dateien hat, bitte PN an mich.


    Vielleicht hat ja jemand tiefergreifende Kenntnisse davon und Interesse, sich damit auseinander zu setzen.

  • Hier die ausgelesenen Dateien. Fotos folgen morgen, sind derzeit zu groß, um sie hier anzuhängen. Die muss ich irgendwie noch kleiner bekommen / zuschneiden. Sind irgendwelche Bereiche von den Boards / Fotos besonders interessant? Dann könnte ich die Bilder auf den entsprechenden Bereich zuschneiden.


    Dateinamen:


    BN41-01929C - funktionierendes board ausgelesen.bin (das muss natürlich BN41-01939C heißen)

    Dieses Board ist jetzt verbaut im TV, damit funktioniert er wieder. Weitere BN-Nummer (die entscheidende) laut Aufkleber: BN9500965B


    BN41-01939A original, defektes board ausgelesen.bin

    Defektes Board. Weitere BN-Nummer laut Aufkleber: BN9500965A


    BN41-01939C nicht funktionierendes board ausgelesen.bin

    Weitere BN-Nummer laut Data-Matrix-Code auf Aufkleber: BN9500861B
    ausgelesene t-con.zip

  • kboll


    Ich habe interesse an dein kaputtes T-Con? Kannst du es mir schenken?


    Danke

    Mach gute Fotos rein mit Aufkleber.


    bei dir BN41-01939C nicht funktionierendes board ausgelesen.bin. da hat wohl nichts geklappt!!!! Es sind alles FFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFFF


    Du sollst Induktivitäten bei CON4 prüfen/auf 55 Zoll umlöten und mit Daten entweder von defektem oder funktionierendem proggen!!!!!!!!!!!!!!


    Dann funzt auch)


    BN95-00861B stammt von einem 46 Zoll!!! Da muss auf 55 Zoll Hardware und Software angepasst werden!!!!!!!!!

  • Das defekte T-Con kannst Du haben, gegen Übernahme der Versandkosten. Alternativ kannst du es auch gerne abholen, sofern du in der Nähe wohnst. Bitte PN bei Interesse, wir finden einen Weg.


    Das nicht funktionierende Board werde ich neu auslesen, habe derzeit allerdings wenig Zeit (daher auch noch keine Fotos). Ich liege mit einer fiesen Erkältung seit ein paar Tagen flach und komme nur sporadisch dazu, Beiträge zu lesen.

    Antwort kann also etwas dauern.

  • So, nun bin ich endlich wieder einigermaßen fit. Im Anhang ein Foto von den Aufklebern auf dem defekten T-Con. Wenn weitere Fotos / Ausschnitte gewünscht sind, bitte melden. Die Beschränkung auf max. 1 MB Dateigröße lässt nicht wriklich große detailreiche Aufnahmen zu.

    Die ausgelesenen Daten vom nicht richtig funktionierenden Board liegen auch im Anhang (neues Board.zip). Beim letzten Mal war das offenbar eine falsche Datei.


    Vielen Dank für den Hinweis mit dem 46"-Board, das muss ich mir noch mal genauer ansehen.

    neues board.zip