Sie sind nicht angemeldet.

RepData Webshop - Hier gibt's die Ersatzteile
Neue Seite 1

Hier geht's zum Shop

 

Lieber Besucher, herzlich willkommen bei: RepData Forum. Falls dies Ihr erster Besuch auf dieser Seite ist, lesen Sie sich bitte die Hilfe durch. Dort wird Ihnen die Bedienung dieser Seite näher erläutert. Darüber hinaus sollten Sie sich registrieren, um alle Funktionen dieser Seite nutzen zu können. Benutzen Sie das Registrierungsformular, um sich zu registrieren oder informieren Sie sich ausführlich über den Registrierungsvorgang. Falls Sie sich bereits zu einem früheren Zeitpunkt registriert haben, können Sie sich hier anmelden.

Mr.Cool

Schüler

  • »Mr.Cool« ist der Autor dieses Themas

Beiträge: 150

Wohnort: Steyr/Oö

Beruf: Monteur

  • Nachricht senden

1

Mittwoch, 23. Juli 2008, 23:01

Pokerautomat schreibt "RAM SETUP ERROR"

Bitte die Beitragsschablone sorgfältig ausfüllen.!!

Gerät: Pokerautomat
Hersteller: Funworld
Modell:MiniFun
Bereits durchgeführte Tests und Vorarbeiten: Netzteil repariert ,Programmplatine gereinigt und zT. repariert
pufferbatterie getauscht



hallo liebe freunde !
ich habe hier einen pokerautomaten von funworld vor mir....... der name ist " minifun"
ich habe erstmal das NT wieder in schuss gebracht (elkos platt , netzgleichrichter und sicherung defekt)
dann wurden am bildschirm bunte kästchen sichtbar............bei schnellem aus und einschalten des gerätes sah ich dann die meldung "RAM SETUP ERROR" in türkisfarbener schrift in der mitte des bildschirms (typischer fall von "verbrummter spannung" sekundär)
ich tauschte alle elkos auf der programmplatine und nun kamen keine bunten kästchen mehr, sondern nurmehr die "RAM SETUP ERROR " meldung !
vielleicht kennt irgendjemand diese meldung bei so einem pokerautomaten ?
ich hänge mal einpaar fotos an........:)

und von der programmplatine.........

....im voraus gesagt ...... die 3 grünen zellen auf der programmplatine ist die neue pufferbatterie !m
vielleicht erkennt jemand dieses gerät oder die platine (?!) und kann mir weiterhelfen ?
zur weiteren info : ich habe mit FUNWORLD telefoniert und sie sagen dass sie diese platine nicht kennen bzw eine fremdfertigung sein müsste
nachdem alle aufkleber fehlen weiss ich in diesem punkt auch nicht weiter !?(
»Mr.Cool« hat folgende Bilder angehängt:
  • minifunvorne.jpg
  • minifunseite.jpg
  • programmplatine1.jpg
  • programmplatine2.jpg
  • programmplatine3.jpg
Der Fehler liegt beim Hersteller des Gerätes
L.G. Mr.Cool

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Mr.Cool« (23. Juli 2008, 23:22)


2

Donnerstag, 24. Juli 2008, 00:04

Hat der alte Akku auf die Platine gekotzt? Falls ja: WIRKLICH alles sauber gemacht...?
Ansonsten das RAM selbst mal getauscht? EPROM-Alzheimer würde ich bei dem Alter des Gerätes auch nicht ausschliessen wollen. Schwierig ohne Unterlagen, vielleicht braucht er nur ein Init (der Fehler klingt nicht so recht nach defektem RAM, sondern mehr nach fehlenden Parametern) - die Prozedur dafür involviert mit Sicherheit Kopfstände, das gleichzeitige Drücken aller Tasten mit der Nasenspitze usw.
Leider (oder zu Glück?) hatten wir das Ding damals nicht im Programm und auch nicht zur Reparatur, aber andere Funworld-Konstruktionen waren durchaus etwas nervig ...

Mr.Cool

Schüler

  • »Mr.Cool« ist der Autor dieses Themas

Beiträge: 150

Wohnort: Steyr/Oö

Beruf: Monteur

  • Nachricht senden

3

Donnerstag, 24. Juli 2008, 19:17

hallo shaun !
erstmal danke für die rasche antwort :)

also den pufferakku hab ich getauscht und alles rundum gereinigt
es sind mehrere leiterbahnen von feuchtigkeitskorrosion befallen aber nicht unterbrochen (lt. durchgangsmessungen)

zum RAM :
da sitzen 2 ic´s , der eine ein tc5517cpl-15 (statisches ram) und der srm2064c15 (statisches ram)

was ich noch hinzufügen wollte : ich hatte die kontakte eines schlüsselschalters mal testhalber überbrückt und war dann in einem "eigenartigen" menü das mir die wertigkeiten eines gewinnes und die gesamteinsätze anzeigte ?(

gibt es irgendwo noch billig solche "programmkarten" zu kaufen ?
gibt es irgendwo im "netz" schaltpläne , software oder bedienungsanleitungen ?

einpaar bilder noch .........
lg und danke für jede info !!
»Mr.Cool« hat folgende Bilder angehängt:
  • CpuPlatine.jpg
  • Korrosion.jpg
Der Fehler liegt beim Hersteller des Gerätes
L.G. Mr.Cool

4

Donnerstag, 24. Juli 2008, 20:51

Zitat

Original von Mr.Cool

es sind mehrere leiterbahnen von feuchtigkeitskorrosion befallen aber nicht unterbrochen (lt. durchgangsmessungen)


Hast du denn auch nach den Durchkontaktierungen gemessen? Möchte wetten, daß die ein oder andere auch was abbekommen hat.

Gruß
repman

Mr.Cool

Schüler

  • »Mr.Cool« ist der Autor dieses Themas

Beiträge: 150

Wohnort: Steyr/Oö

Beruf: Monteur

  • Nachricht senden

5

Donnerstag, 24. Juli 2008, 21:25

@repman
die durchkontaktierung hab ich gemessen ---> ok


man wird sich fragen warum ich soviel aufwand betreibe......
nun ...... das "ding" ist mittlerweile ein nostalgiegerät mit veralteter technik/elektronik
ich selber hab dazumal darauf gespielt und es hat mich fasziniert !

nun hab ich so ein ding in den händen und möchte es wieder zum "leben erwecken" !


danke für eure anteilnahme !!!8) :) :) :)
Der Fehler liegt beim Hersteller des Gerätes
L.G. Mr.Cool

6

Donnerstag, 24. Juli 2008, 21:43

Dann sichere mal vor weiterer Fehlersuche die EPROM-Inhalte, wäre doch ärgerlich, wenn eins beim Messen oder kurz nach erfolgreicher Instandsetzung aufgibt. Wenn es bis jetzt noch ok ist natürlich...

Wie geschrieben, ich hatte zwar Geräte dieses Premiumherstellers unter der Fuchtel, aber nichts mit einer vergleichbaren CPU-Karte. Wenn das RAM ausgeschlossen werden kann, müsste man wohl wirklich mal versuchen herauszufinden, ob das Ding initialisiert werden muss.

Mr.Cool

Schüler

  • »Mr.Cool« ist der Autor dieses Themas

Beiträge: 150

Wohnort: Steyr/Oö

Beruf: Monteur

  • Nachricht senden

7

Donnerstag, 24. Juli 2008, 22:07

ich kann leider diese inhalte nicht sichern weil ich die nötige hw /sw nicht habe !8)
"shit"
was für eine hw und sw sollte ich mir besorgen ?


lg und danke
Der Fehler liegt beim Hersteller des Gerätes
L.G. Mr.Cool

8

Freitag, 25. Juli 2008, 07:32

moin,
gugl mal nach ponyprog... auf den sites gibts auch genügend (selbstbau)adapter für verschiedenste mems.
Ich bin nur für das verantwortlich was ich schreibe
und nicht dafür wie es jemand versteht !

9

Freitag, 25. Juli 2008, 09:04

Das ist aber schon ne Menge Gebastel. Ich habe mir irgendwann mal den Willem zusammengebastelt, aber für den Alltag bevorzuge ich unseren Advantech ;)

Chips

Erleuchteter

Beiträge: 3 190

Wohnort: Südpfalz

Beruf: ex-RFT

  • Nachricht senden

10

Freitag, 25. Juli 2008, 15:01

ausrangierte Data-I/O oder Sprint sind auch nicht schlecht, z.B. ChipLab,
ausser UniSite oder 29B
Gruß
Chips

11

Freitag, 25. Juli 2008, 15:37

Was hast Du denn gegen den 29B? Für einige Uralt-PROMs hat das Ding hier schon hervorragende Dienste geleistet. Spätestens bei EPROMs, die nach negativen Spannungen schreien, kotzen die ganzen modernen Teile doch gnadenlos ab.

secondtech

Fortgeschrittener

Beiträge: 458

Wohnort: Wuppertal

Beruf: Techniker

  • Nachricht senden

12

Freitag, 25. Juli 2008, 18:57

Wie bist Du denn aus dem "eigenartigen Menü" wieder rausgegangen ?
Das ist das Setup-menü des Gerätes, wo unter anderen auch die Parameter für die Hardware festgelegt werden. Beim Verlassen des
Menüs auf unüblichem Weg ( z.B. einfach ausschalten ) befindet sich das Gerät in einem undefinierten Zustand und jammert.

Kommst Du noch in dieses Menü ?
Leichte Hochspannungsschläge fördern das Denkvermögen und andere Dinge.

Mr.Cool

Schüler

  • »Mr.Cool« ist der Autor dieses Themas

Beiträge: 150

Wohnort: Steyr/Oö

Beruf: Monteur

  • Nachricht senden

13

Freitag, 25. Juli 2008, 19:30

hallo secondtech ! :)

ja ich komme wieder in das menü.
ich werde noch einpaar bilder von "meldungen" ("ram setup error" und dem "menü" posten

zum "eigenartigen" menü gesagt:
es ist kein menü im herkömmlichen sinn ,wie zb ein biossetup-aufruf bei einem pc wo man runter und raufscrollen kann und menüpunkte aufrufen kann
sondern ich kann nur mit einer taste zwischen den "wertigkeiten" und den "einsätzen" hin und herschalten.
mit einer anderen taste komm ich wieder aus dem "menü"raus und es steht dann wieder "ram setup error" am schirm.
dann kann ich drücken was ich will aber es bleibt nur diese meldung am schirm.

aber wie gesagt ,zum besseren vorstellen werde ich noch einpaar bilder posten.

lg und herzlichen dank für eure hilfe !
Der Fehler liegt beim Hersteller des Gerätes
L.G. Mr.Cool

Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von »Mr.Cool« (25. Juli 2008, 19:36)


Mr.Cool

Schüler

  • »Mr.Cool« ist der Autor dieses Themas

Beiträge: 150

Wohnort: Steyr/Oö

Beruf: Monteur

  • Nachricht senden

14

Sonntag, 27. Juli 2008, 13:20

so ! nun noch einpaar screenshots der "menüs".... und der programmplatine mit losem stecker(möglicherweise zum einspielen von daten ?)
die kleine platine mit den 4 blauen dipswitches ist mit den kontakten des linken schlüsselschalters verbunden (weisser und roter draht) wenn man diese 2 kontakte verbindet tut sich gar nix ,ebenso die rote led bleibt dunkel
was man alles mit den roten dipswitches einstellen kann weiss ich leider auch nicht genau, ich denke da kann man auf jeden fall das einzahl/gewinn verhältnis manipulieren

herzlichen dank für eure anteilnahme!
»Mr.Cool« hat folgende Bilder angehängt:
  • 1.jpg
  • 2.jpg
  • 3.jpg
  • 4.jpg
  • 5.jpg
Der Fehler liegt beim Hersteller des Gerätes
L.G. Mr.Cool

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Mr.Cool« (27. Juli 2008, 14:22)


secondtech

Fortgeschrittener

Beiträge: 458

Wohnort: Wuppertal

Beruf: Techniker

  • Nachricht senden

15

Sonntag, 27. Juli 2008, 21:07

Das mit dem Schlüsselschalter und den DIPs hört sich interessant an.

Hab mal ( vor sehr langer Zeit ) mit Spielautomaten zu tun gehabt.

Bei vielen wurde über den Schlüsselschalter und DIPs zwischen verschiedenen Service-Modes gewählt.

Der logische Aufbau war in etwa :

DIP-1 : Normalmode/Servicemode
DIP-2 : auto/man ( auto = gerät läuft in einem durch
man = taste ganz rechts = enter
taste daneben = modify
tasten daneben vor/zurück oder up/down
DIP-3 : enable/clear bookfactory
DIP-4 : on = reset factory defaults

Würde mit DIP 1 = ON anfangen und schauen, was sich tut.

Dein Problem hängt damit zusammen, das im RAM keine sinnvollen Werte mehr stehen.
Leichte Hochspannungsschläge fördern das Denkvermögen und andere Dinge.

16

Sonntag, 27. Juli 2008, 22:10

Das habe ich ja auch schon anspekuliert, als die Nennung der Fehlermeldung hier zum ersten Mal erfolgte - dass das RAM wahrscheinlich nicht defekt, sondern schlicht nur nicht initialisiert ist.

Kennst Du explizit diese CPU? Irgendwie scheint mir die Nennung von DIP-Schalter-Bedeutungen sonst etwas spanisch. Ich hatte seinerzeit mit Darts (Löwen und noch irgendwas), Flippern (durch die Reihe - Sega, Gottlieb, Williams inkl Pinball 2000,...), Videokrams aller Art und diversem Frickelwerk einheimischer und insulaner (Barcrest - börks!) Produktion zu tun und kann nicht bestätigen, dass die Bedeutung von DIP-Schalter in irgendeiner Form genormt ist ;)

Die kleine Platine scheint mir auch nachträglich bzw optional eingebaut zu sein, ein programmiertes Irgendwas und ein Darlington-Leistungstreiber stinkt danach als solle da irgendwas sonst durch Tasten realisiertes universell ersetzt werden. Um Logikeingänge zu steuern, braucht's keine 500mA-Treiber.
Ich würde erstmal versuchen sicherzustellen, dass die CPU-Karte korrekt arbeitet (zugegeben - für ein Einzelstück eine Testsoftware zu schreiben ist nicht bezahlbar), dann auf jeden Fall die Einstellprozedur für die Initialisierung herauszufinden versuchen - weiter rumfragen oder viel, viel probieren und dann mal antesten, was die kleine Zusatzplatine so macht, d.h. welche Leitungen Ausgänge sind (Tendenz: alle bis auf Vcc und GND) und was die so treiben.

BTW. gibt es für das Cabinet auch andere Boards? Der Direktstecker spricht dafür, vielleicht sogar was, worüber sich Informationen finden und ggf. anhand derer die vielleicht hier fehlenden Setup-Taster nachrüsten lassen?
Jamma hat nur 2x28 Pins, das sieht mehr nach 2x36 aus, aber die unteren sind nicht belegt. Zufall?

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »shaun« (27. Juli 2008, 22:12)


secondtech

Fortgeschrittener

Beiträge: 458

Wohnort: Wuppertal

Beruf: Techniker

  • Nachricht senden

17

Dienstag, 29. Juli 2008, 17:42

Schau mal nach ob das Board folgende Bauteile enthält :

cpu M65SC02 @ 2MHz
audio AY-3-8910A @ 2MHz
7 Knöpfe

Bios : 82s147

Leider beziehen sich die weiteren Angaben auf den spielemulator mame.

Danach kann man das RAM wie folgt initialisieren.

press and hold servicekey and key 0 and 9, then press reset, the nvram has been initialisied.

Da ich das bios noch nicht habe, kann ich dir jetzt noch nicht sagen, auf welche Buttons sich die Angaben beziehen.

Bin aber dabei das herunter zu laden und kann Dir dann weiteres berichten.

Vielleicht hat da dann auch jemand dieses Zusatzschaltung mit dem Schlüsselschalter eingebaut, um sich diese Spagatgriffe zu ersparen.

Sobald ich das Bios habe, kann ich Dir mehr sagen.

Die Firma hat aber auch nur insgsamt 3 unterschiedliche Geräte produziert, sehr wahrscheinlich auch noch in Kleinserie.

Könnte Dir dann auch das Bios sowie den Inhalt des initialiserten nvrams zukommen lassen. Bestimmt findet sich hier jemand, der Dir das dann auf die Chips bringt.

Gerät wurde von Soft Design geclont und heisst da Royal Vegas Joker Card


Bedeutung der DIPs auf der Hauptplatine :

State Keyboard
0=Test
1= Play

Remote
0= 10 Points/Pulse
1= 100 Points/Pulse

Coin B
0= 5 Points/Coin
1= 10 Points/Coin

Coin A
0= 5 Points/Coin
1= 10 Points/Coin

Insert
0= Dattl Insert
1= TAB Insert

Joker
0= With Joker
1= Without Joker

Hold
0= Auto Hold
1= No Auto Hold

Payout
0= Hopper
1= Manual Payout SW
Leichte Hochspannungsschläge fördern das Denkvermögen und andere Dinge.

Dieser Beitrag wurde bereits 5 mal editiert, zuletzt von »secondtech« (29. Juli 2008, 18:10)


Mr.Cool

Schüler

  • »Mr.Cool« ist der Autor dieses Themas

Beiträge: 150

Wohnort: Steyr/Oö

Beruf: Monteur

  • Nachricht senden

18

Dienstag, 29. Juli 2008, 20:11

hallo secondtech !
du bist echt klasse !!
also vorweggesagt .............
die kleine platine ist ein sogenanntes "kellnerschlosssystem" womit der kellner (bis zu 4 kellnerschlüssel programmierbar)zugang zu gewissen einstellungen und daten am gerät hat
punkte/geld für den spieler aufstocken oä.
ein link von einer etwas neueren platine:
http://www.championsnet.net/fedoc_dokume…loss_TAB_de.pdf

zu den hardwarefragen :

CPU :R65C02P2
AUDIO : AY-3-8910A (auf dem mainboard)
M27C256B-12 (auf der gesteckten cpu platine)

7Knöpfe
von links :
1:nehmen/löschen 2:halten 3:halten/tief 4:halten 5:halten 6:halten/einsatz/1/2-nehmen 7:start/gamble


ich hänge noch einpaar bilder an...........


herzlichsten dank !8)
»Mr.Cool« hat folgende Bilder angehängt:
  • IMGP0561.jpg
  • IMGP0564.jpg
  • IMGP0554.jpg
Der Fehler liegt beim Hersteller des Gerätes
L.G. Mr.Cool

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »Mr.Cool« (29. Juli 2008, 20:13)


secondtech

Fortgeschrittener

Beiträge: 458

Wohnort: Wuppertal

Beruf: Techniker

  • Nachricht senden

19

Dienstag, 29. Juli 2008, 21:45

Habe das Bios im Emulator gestartet. Leider meldet es einen Elektronikdefekt.

Leider geht aus der Tastenbelegung auch nicht hervor, welche Buttons welche Funktion im Service-Mode haben.

Ersichtlich wird nur, das es noch 2 zusätzliche Schalter/DIPs geben muss.

Der eine schaltet die Buchhaltung ein/aus, der andere den Servicemode. Werden beide zusammen eingeschaltet, muss man wohl noch bestimmte Buttons drücken; ob beim Einschalten oder falls vorhanden Drücken eines Reset-Tasters, kann ich Dir leider nicht sagen.

Könnte vielleicht am dem freien Kabelende gehangen haben.
Leichte Hochspannungsschläge fördern das Denkvermögen und andere Dinge.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »secondtech« (29. Juli 2008, 21:46)


secondtech

Fortgeschrittener

Beiträge: 458

Wohnort: Wuppertal

Beruf: Techniker

  • Nachricht senden

20

Dienstag, 29. Juli 2008, 21:59

Also hier ist so hoffe ich die Lösung.

DIP-Schalter für State Keyboard, ist der ganz rechts auf 1 umstellen.
Dannach erscheint auf dem Display RAMS nitialisiert

Zumindest geht so hier mit den DIP-Schaltern.
Leichte Hochspannungsschläge fördern das Denkvermögen und andere Dinge.

Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von »secondtech« (29. Juli 2008, 22:07)


Thema bewerten